CVE-2025-68151
Fixed in a distro release EPSS <1%CVSS 6.6
CoreDNS is a DNS server that chains plugins. Prior to version 1.14.0, multiple CoreDNS server implementations (gRPC, HTTPS, and HTTP/3) lack critical resource-limiting controls. An unauthenticated remote attacker can exhaust memory and degrade or crash the server by opening many concurrent connections, streams, or sending oversized request bodies. The issue is similar in nature to CVE-2025-47950 (QUIC DoS) but affects additional server types that do not enforce connection limits, stream limits, or message size constraints. Version 1.14.0 contains a patch.
Products: coredns
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/coredns/coredns | 1.14.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | cloudflared | 2026.2.0-r0 |
| Chainguard | cloudflared-fips | 2026.2.0-r0 |
| Chainguard | coredns-1.12 | no fix |
| Chainguard | coredns-1.13 | no fix |
| Chainguard | coredns-fips-1.13 | no fix |
| Chainguard | eks-distro-coredns-1.29 | no fix |
| Chainguard | eks-distro-coredns-1.30 | no fix |
| Chainguard | eks-distro-coredns-1.31 | 1.31.43-r2 |
| Chainguard | eks-distro-coredns-1.32 | 1.32.31-r1 |
| Chainguard | eks-distro-coredns-1.33 | 1.33.25-r1 |
| Chainguard | eks-distro-coredns-1.34 | 1.34.17-r2 |
| Chainguard | eks-distro-coredns-1.35 | 1.35.7-r1 |
| Chainguard | eks-distro-coredns-fips-1.29 | no fix |
| Chainguard | eks-distro-coredns-fips-1.30 | no fix |
| Chainguard | eks-distro-coredns-fips-1.31 | 1.31.43-r2 |
| Chainguard | eks-distro-coredns-fips-1.32 | 1.32.31-r1 |
| Chainguard | eks-distro-coredns-fips-1.33 | 1.33.25-r1 |
| Chainguard | eks-distro-coredns-fips-1.34 | 1.34.17-r2 |
| Chainguard | eks-distro-coredns-fips-1.35 | 1.35.7-r1 |
| Chainguard | kuma-coredns-1.12 | no fix |
| Chainguard | kuma-coredns-1.13 | no fix |
| Wolfi | cloudflared | 2026.2.0-r0 |
| Wolfi | coredns-1.13 | no fix |
| Wolfi | kuma-coredns-1.13 | no fix |
| openSUSE Leap 15.6 | govulncheck-vulndb | 0.0.20260114T191543-150000.1.137.1 |
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |