Patchwire CVEs, their patch status, and feeds to follow them

CVE-2025-67746

Fixed in a distro release EPSS <1%CVSS 1.3

Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.

Published 2025-12-30 · CVE record · OSV

Products: composer

Fixed upstream

EcosystemPackageFixed in
Packagistcomposer/composer2.2.26
Packagistcomposer/composer2.9.3

Distro releases

ReleasePackageFixed in
Debian 12composer2.5.5-1+deb12u3
Debian 13composer2.8.8-1+deb13u1
Debian 14composer2.9.3-1
Red Hat hummingbird 1composer0:2.9.7-1.hum1
SUSE Linux Enterprise Module for Web and Scripting 15 SP7php-composer22.6.4-150600.3.6.1
SUSE Linux Enterprise Module for Web and Scripting 15 SP7php-composer22.6.4-150600.3.12.1
SUSE Linux Enterprise Server 15 SP6-LTSSphp-composer22.6.4-150600.3.12.1
SUSE Linux Enterprise Server 16.0php-composer22.8.9-160000.4.1
SUSE Linux Enterprise Server for SAP Applications 15 SP6php-composer22.6.4-150600.3.12.1
SUSE Linux Enterprise Server for SAP applications 16.0php-composer22.8.9-160000.4.1
Ubuntu 25.10composerno fix
Ubuntu 26.04 LTScomposerno fix
Ubuntu Pro 16.04 LTScomposerno fix
Ubuntu Pro 18.04 LTScomposerno fix
Ubuntu Pro 20.04 LTScomposerno fix
Ubuntu Pro 22.04 LTScomposerno fix
Ubuntu Pro 24.04 LTScomposerno fix
openSUSE Leap 15.6php-composer22.6.4-150600.3.6.1
openSUSE Leap 16.0php-composer22.8.9-160000.4.1
openSUSE Tumbleweedphp-composer22.9.3-1.1