CVE-2025-67635
Fixed in a distro release EPSS <1%CVSS 7.5
Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI connections when the connection stream becomes corrupted, allowing unauthenticated attackers to cause a denial of service.
Products: Jenkins project Jenkins
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.jenkins-ci.main:cli | 2.541 |
| Maven | org.jenkins-ci.main:cli | 2.528.3 |
| Maven | org.jenkins-ci.main:jenkins-core | 2.541 |
| Maven | org.jenkins-ci.main:jenkins-core | 2.528.3 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | jenkins-2.504-openjdk-17 | no fix |
| Chainguard | jenkins-2.504-openjdk-21 | no fix |
| Chainguard | jenkins-2.516-openjdk-17 | 2.516.3-r4 |
| Chainguard | jenkins-2.516-openjdk-21 | 2.516.3-r4 |
| Chainguard | jenkins-2.528 | 2.528.3-r2 |