CVE-2025-66675
Fixed upstream EPSS <1%CVSS 8.2
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue. It's related to https://cve.org/CVERecord?id=CVE-2025-64775 - this CVE addresses missing affected version 6.7.4
Products: Apache Software Foundation Apache Struts
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.struts:struts2-core | 6.8.0 |
| Maven | org.apache.struts:struts2-core | 7.1.1 |