CVE-2025-66168
Fixed in a distro release EPSS <1%CVSS 5.4
WARNING: Users of 6.x should upgrade to 6.2.4 or later as the fix was missed in previous 6.x releases. See the following for more details: https://activemq.apache.org/security-advisories.data/CVE-2026-40046-announcement.txt https://www.cve.org/CVERecord?id=CVE-2026-40046 Original Report: Apache ActiveMQ does not properly validate the remaining length field which may lead to an overflow during the decoding of malformed packets. When this integer overflow occurs, ActiveMQ may incorrectly compute the total Remaining Length and subsequently misinterpret the payload as multiple MQTT control packets which makes the broker susceptible to unexpected behavior when interacting with non-compliant clients. This behavior violates the MQTT v3.1.1 specification, which restricts Remaining Length to a maximum of 4 bytes. The scenario occurs on established connections after the authentication process. Brokers that are not enabling mqtt transport connectors are not impacted. This issue affects Apache ActiveMQ: before 5.19.2, 6.0.0 to 6.1.8, and 6.2.0 Users are recommended to upgrade to version 5.19.2, 6.1.9, or 6.2.1, which fixes the issue.
Products: Apache Software Foundation Apache ActiveMQ, Apache Software Foundation Apache ActiveMQ All Module, Apache Software Foundation Apache ActiveMQ MQTT Module
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.activemq:activemq-all | 5.19.2 |
| Maven | org.apache.activemq:activemq-all | 6.1.9 |
| Maven | org.apache.activemq:activemq-all | 6.2.1 |
| Maven | org.apache.activemq:activemq-mqtt | 5.19.2 |
| Maven | org.apache.activemq:activemq-mqtt | 6.1.9 |
| Maven | org.apache.activemq:activemq-mqtt | 6.2.1 |
| Maven | org.apache.activemq:apache-activemq | 5.19.2 |
| Maven | org.apache.activemq:apache-activemq | 6.1.9 |
| Maven | org.apache.activemq:apache-activemq | 6.2.1 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | apache-activemq-6.1 | no fix |
| Chainguard | apache-activemq-fips-6.1 | no fix |
| Chainguard | geoserver-2.27-community | 2.27.5-r2 |
| Chainguard | geoserver-2.28-community | 2.28.2-r3 |
| Debian 12 | activemq | no fix |
| Debian 13 | activemq | no fix |
| Ubuntu 24.04 LTS | activemq | no fix |
| Ubuntu 25.10 | activemq | no fix |
| Ubuntu 26.04 LTS | activemq | no fix |
| Ubuntu 26.10 | activemq | no fix |
| Ubuntu Pro 16.04 LTS | activemq | no fix |
| Ubuntu Pro 18.04 LTS | activemq | no fix |
| Ubuntu Pro 20.04 LTS | activemq | no fix |
| Ubuntu Pro 22.04 LTS | activemq | no fix |