CVE-2025-6594
Fixed in a distro release EPSS <1%CVSS 4.7
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files resources/src/mediawiki.Special.Apisandbox/ApiSandbox.Js. This issue affects MediaWiki: from 1.27.0 before 1.39.13, 1.42.7 1.43.2, 1.44.0.
Products: Wikimedia Foundation MediaWiki
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian:11 | mediawiki | 1:1.35.13-1+deb11u4 |
| Debian:12 | mediawiki | 1:1.39.13-1~deb12u1 |
| Debian:13 | mediawiki | 1:1.43.3+dfsg-1 |
| Debian:14 | mediawiki | 1:1.43.3+dfsg-1 |
| Ubuntu:18.04:LTS | mediawiki | no fix |
| Ubuntu:25.10 | mediawiki | no fix |
| Ubuntu:26.04:LTS | mediawiki | no fix |
| Ubuntu:26.10 | mediawiki | no fix |
| Ubuntu:Pro:20.04:LTS | mediawiki | no fix |
| Ubuntu:Pro:22.04:LTS | mediawiki | no fix |
| Ubuntu:Pro:24.04:LTS | mediawiki | no fix |