Patchwire CVEs, their patch status, and feeds to follow them

CVE-2025-64775

Fixed upstream EPSS 2%CVSS 7.5

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.

Published 2025-12-01 · CVE record · OSV

Products: Apache Software Foundation Apache Struts

Fixed upstream

EcosystemPackageFixed in
Mavenorg.apache.struts:struts2-core6.8.0
Mavenorg.apache.struts:struts2-core7.1.1
Mavenorg.apache.struts:struts2-coreno fix