CVE-2025-64761
Fixed in a distro release EPSS <1%CVSS 7.5
OpenBao is an open source identity-based secrets management system. Prior to version 2.4.4, a privileged operator could use the identity group subsystem to add a root policy to a group identity group, escalating their or another user's permissions in the system. Specifically this is an issue when: an operator in the root namespace has access to identity/groups endpoints and an operator does not have policy access. Otherwise, an operator with policy access could create or modify an existing policy to grant root-equivalent permissions through the sudo capability. This issue has been patched in version 2.4.4.
Products: openbao
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/openbao/openbao | 2.4.4 |
| Go | github.com/openbao/openbao | no fix |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| SUSE:Linux Enterprise Module for Package Hub 15 SP6 | govulncheck-vulndb | 0.0.20251209T172047-150000.1.127.1 |
| openSUSE:Leap 15.6 | govulncheck-vulndb | 0.0.20251209T172047-150000.1.127.1 |
| openSUSE:Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |
| openSUSE:Tumbleweed | openbao | 2.4.4-1.1 |