CVE-2025-62690
Fixed in a distro release EPSS <1%CVSS 3.1
Mattermost versions 10.11.x <= 10.11.4 fail to validate redirect URLs on the /error page, which allows an attacker to redirect a victim to a malicious site via a crafted link opened in a new tab.
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost | 10.11.5-0.20251016131338-dad6bd7a1509 |
| Go | github.com/mattermost/mattermost | 11.1.0 |
| Go | github.com/mattermost/mattermost | 11.1.0+incompatible |
| Go | github.com/mattermost/mattermost-server | no fix |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20251016131338-dad6bd7a1509 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE Leap 15.6 | govulncheck-vulndb | 0.0.20260114T191543-150000.1.137.1 |
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |