CVE-2025-62593
Fixed in a distro release ExploitedEPSS 62%CVSS 9.4
Ray is an AI compute engine. Prior to version 2.52.0, developers working with Ray as a development tool can be exploited via a critical RCE vulnerability exploitable via Firefox and Safari. This vulnerability is due to an insufficient guard against browser-based attacks, as the current defense uses the User-Agent header starting with the string "Mozilla" as a defense mechanism. This defense is insufficient as the fetch specification allows the User-Agent header to be modified. Combined with a DNS rebinding attack against the browser, and this vulnerability is exploitable against a developer running Ray who inadvertently visits a malicious website, or is served a malicious advertisement (malvertising). This issue has been patched in version 2.52.0.
Products: ray-project ray
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | ray | 2.52.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | airflow-3 | 3.2.0-r0 |
| Chainguard | airflow-3-bitnami-compat | 0 |
| Chainguard | py3-vllm-cuda-12.4 | 0.11.2-r1 |
| Chainguard | py3.12-vllm-cuda-12.4 | 0.11.2-r1 |
| Chainguard | tritonserver-backend-vllm-meta-cuda-12.9 | 25.9.0_git20251112-r1 |
| Wolfi | airflow-3 | 3.2.0-r0 |
| Wolfi | airflow-3-bitnami-compat | 0 |