CVE-2025-62164
Fixed in a distro release EPSS <1%CVSS 8.8
vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.
Products: vllm-project vllm
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | vllm | 0.11.1 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | tritonserver-backend-vllm-cuda-12.9 | 25.9.0_git20251112-r1 |
| Chainguard | tritonserver-backend-vllm-meta-cuda-12.9 | 25.9.0_git20251112-r1 |