CVE-2025-59420
Fixed in a distro release EPSS <1%CVSS 7.5
Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.4, Authlib’s JWS verification accepts tokens that declare unknown critical header parameters (crit), violating RFC 7515 “must‑understand” semantics. An attacker can craft a signed token with a critical header (for example, bork or cnf) that strict verifiers reject but Authlib accepts. In mixed‑language fleets, this enables split‑brain verification and can lead to policy bypass, replay, or privilege escalation. This issue has been patched in version 1.6.4.
Products: authlib
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | authlib | 1.6.4 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | mlflow | 3.4.0-r1 |
| Chainguard | mlflow-iamguarded-compat | 3.4.0-r1 |
| Chainguard | open-webui | 0.6.30-r1 |
| Chainguard | open-webui-compat | 0.6.30-r1 |
| Chainguard | pgadmin4 | 9.8-r1 |
| Chainguard | pgadmin4-oci-entrypoint | 9.8-r1 |
| Debian 11 | python-authlib | 0.15.4-1+deb11u1 |
| Debian 12 | python-authlib | 1.2.0-1+deb12u1 |
| Debian 13 | python-authlib | 1.6.0-1+deb13u1 |
| Debian 14 | python-authlib | 1.6.4-1 |
| Ubuntu 25.10 | python-authlib | no fix |
| Ubuntu 26.10 | python-authlib | no fix |
| Ubuntu Pro 22.04 LTS | python-authlib | 0.15.5-1ubuntu0.1~esm1 |
| Ubuntu Pro 24.04 LTS | python-authlib | 1.3.0-1ubuntu0.1~esm1 |
| Ubuntu Pro 26.04 LTS | python-authlib | no fix |
| Wolfi | mlflow | 3.4.0-r1 |
| Wolfi | mlflow-iamguarded-compat | 3.4.0-r1 |
| Wolfi | open-webui | 0.6.30-r1 |
| Wolfi | open-webui-compat | 0.6.30-r1 |