CVE-2025-58073
Fixed in a distro release EPSS <1%CVSS 8.1
Mattermost versions 10.11.x <= 10.11.1, 10.10.x <= 10.10.2, 10.5.x <= 10.5.10 fail to verify a user has permission to join a Mattermost team using the original invite token which allows any attacked to join any team on a Mattermost server regardless of restrictions via manipulating the OAuth state.
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost-server | 10.11.2 |
| Go | github.com/mattermost/mattermost-server | 10.10.3 |
| Go | github.com/mattermost/mattermost-server | 10.5.11 |
| Go | github.com/mattermost/mattermost-server | 10.5.11+incompatible |
| Go | github.com/mattermost/mattermost-server | 10.10.3+incompatible |
| Go | github.com/mattermost/mattermost-server | 10.11.2+incompatible |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20250807174701-e14175eb6539 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |
| openSUSE Tumbleweed | govulncheck-vulndb | 0.0.20251105T184115-1.1 |