CVE-2025-57822
Fixed in a distro release EPSS 3%CVSS 6.5
Next.js is a React framework for building full-stack web applications. Prior to versions 14.2.32 and 15.4.7, when next() was used without explicitly passing the request object, it could lead to SSRF in self-hosted applications that incorrectly forwarded user-supplied headers. This vulnerability has been fixed in Next.js versions 14.2.32 and 15.4.7. All users implementing custom middleware logic in self-hosted environments are strongly encouraged to upgrade and verify correct usage of the next() function.
Products: vercel next.js
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | next | 14.2.32 |
| npm | next | 15.4.7 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | jitsucom-jitsu | 2.11.0-r1 |
| Chainguard | jitsucom-jitsu-console | 2.11.0-r1 |
| Chainguard | jitsucom-jitsu-rotor | 2.11.0-r1 |
| Chainguard | langfuse | 3.106.1-r1 |
| Chainguard | langfuse-compat | 3.106.1-r1 |
| Chainguard | langfuse-worker | 3.106.1-r1 |
| Wolfi | jitsucom-jitsu | 2.11.0-r1 |
| Wolfi | jitsucom-jitsu-console | 2.11.0-r1 |
| Wolfi | jitsucom-jitsu-rotor | 2.11.0-r1 |
| Wolfi | langfuse | 3.106.1-r1 |
| Wolfi | langfuse-compat | 3.106.1-r1 |
| Wolfi | langfuse-worker | 3.106.1-r1 |