CVE-2025-56226
Fixed in a distro release EPSS <1%CVSS 5.3
Libsndfile <=1.2.2 contains a memory leak vulnerability in the mpeg_l3_encoder_init() function within the mpeg_l3_encode.c file.
Products: libsndfile_project libsndfile
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | libsndfile | no fix |
| Debian 13 | libsndfile | 1.2.2-2+deb13u1 |
| Debian 14 | libsndfile | 1.2.2-4 |
| Ubuntu 20.04 LTS | libsndfile | no fix |
| Ubuntu 22.04 LTS | libsndfile | no fix |
| Ubuntu 24.04 LTS | libsndfile | no fix |
| Ubuntu 25.10 | libsndfile | no fix |
| Ubuntu 26.04 LTS | libsndfile | no fix |
| Ubuntu 26.10 | libsndfile | no fix |
| Ubuntu Pro 14.04 LTS | libsndfile | no fix |
| Ubuntu Pro 16.04 LTS | libsndfile | no fix |
| Ubuntu Pro 18.04 LTS | libsndfile | no fix |
| openSUSE Tumbleweed | libsndfile | 1.2.2-4.1 |