CVE-2025-55190
Fixed in a distro release EPSS 6%CVSS 10.0
Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. In versions 2.13.0 through 2.13.8, 2.14.0 through 2.14.15, 3.0.0 through 3.0.12 and 3.1.0-rc1 through 3.1.1, API tokens with project-level permissions are able to retrieve sensitive repository credentials (usernames, passwords) through the project details API endpoint, even when the token only has standard application management permissions and no explicit access to secrets. This vulnerability does not only affect project-level permissions. Any token with project get permissions is also vulnerable, including global permissions such as: `p, role/user, projects, get, *, allow`. This issue is fixed in versions 2.13.9, 2.14.16, 3.0.14 and 3.1.2.
Products: argoproj argo-cd
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/argoproj/argo-cd | no fix |
| Go | github.com/argoproj/argo-cd/v2 | 2.13.9 |
| Go | github.com/argoproj/argo-cd/v2 | 2.14.16 |
| Go | github.com/argoproj/argo-cd/v3 | 3.0.14 |
| Go | github.com/argoproj/argo-cd/v3 | 3.1.2 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | argo-cd-2.13 | 2.13.9-r2 |
| Chainguard | argo-cd-2.13-compat | 2.13.9-r2 |
| Chainguard | argo-cd-2.13-repo-server | 2.13.9-r2 |
| Chainguard | argo-cd-fips-2.13 | 2.13.9-r3 |
| Chainguard | argo-cd-fips-2.13-compat | 2.13.9-r3 |
| Chainguard | argo-cd-fips-2.13-repo-server | 2.13.9-r3 |
| Chainguard | argocd-image-updater | 0.16.0-r8 |
| Chainguard | argocd-image-updater-compat | 0.16.0-r8 |
| Chainguard | argocd-image-updater-fips | 0.16.0-r9 |
| SUSE Linux Enterprise Module for Package Hub 15 SP6 | govulncheck-vulndb | 0.0.20250918T182144-150000.1.107.1 |
| Wolfi | argo-cd-2.13 | 2.13.9-r2 |
| Wolfi | argo-cd-2.13-compat | 2.13.9-r2 |
| Wolfi | argo-cd-2.13-repo-server | 2.13.9-r2 |
| Wolfi | argocd-image-updater | 0.16.0-r8 |
| Wolfi | argocd-image-updater-compat | 0.16.0-r8 |
| openSUSE Leap 15.6 | govulncheck-vulndb | 0.0.20250918T182144-150000.1.107.1 |
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |
| openSUSE Tumbleweed | govulncheck-vulndb | 0.0.20250908T141310-1.1 |