CVE-2025-55157
Fixed in a distro release EPSS <1%CVSS 6.9
Vim is an open source, command line text editor. In versions from 9.1.1231 to before 9.1.1400, When processing nested tuples in Vim script, an error during evaluation can trigger a use-after-free in Vim’s internal tuple reference management. Specifically, the tuple_unref() function may access already freed memory due to improper lifetime handling, leading to memory corruption. The exploit requires direct user interaction, as the script must be explicitly executed within Vim. This issue has been patched in version 9.1.1400.
Products: vim
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| SUSE Linux Enterprise Micro 5.1 | vim | 9.1.1629-150000.5.78.1 |
| SUSE Linux Enterprise Micro 5.2 | vim | 9.1.1629-150000.5.78.1 |
| SUSE Linux Enterprise Micro 5.3 | vim | 9.1.1629-150000.5.78.1 |
| SUSE Linux Enterprise Micro 5.4 | vim | 9.1.1629-150000.5.78.1 |
| SUSE Linux Enterprise Micro 5.5 | vim | 9.1.1629-150500.20.33.1 |
| SUSE Linux Enterprise Module for Basesystem 15 SP6 | vim | 9.1.1629-150500.20.33.1 |
| SUSE Linux Enterprise Module for Basesystem 15 SP7 | vim | 9.1.1629-150500.20.33.1 |
| SUSE Linux Enterprise Module for Desktop Applications 15 SP6 | vim | 9.1.1629-150500.20.33.1 |
| SUSE Linux Enterprise Module for Desktop Applications 15 SP7 | vim | 9.1.1629-150500.20.33.1 |
| SUSE Linux Enterprise Server LTSS Extended Security 12 SP5 | vim | 9.1.1629-17.51.1 |
| SUSE Linux Micro 6.0 | vim | 9.1.1629-1.1 |
| SUSE Linux Micro 6.1 | vim | 9.1.1629-slfo.1.1_1.1 |
| openSUSE Leap 15.6 | vim | 9.1.1629-150500.20.33.1 |