CVE-2025-55073
Fixed in a distro release EPSS <1%CVSS 5.4
Mattermost versions 10.11.x <= 10.11.3, 10.5.x <= 10.5.11, 10.12.x <= 10.12.0 fail to validate the relationship between the post being updated and the MSTeams plugin OAuth flow which allows an attacker to edit arbitrary posts via a crafted MSTeams plugin OAuth redirect URL.
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost-server | 10.11.4 |
| Go | github.com/mattermost/mattermost-server | 10.5.12 |
| Go | github.com/mattermost/mattermost-server | 10.12.1 |
| Go | github.com/mattermost/mattermost-server | 10.5.12+incompatible |
| Go | github.com/mattermost/mattermost-server | 10.11.4+incompatible |
| Go | github.com/mattermost/mattermost-server | 10.12.1+incompatible |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20250929212932-a41db04d2746 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |