CVE-2025-54997
Fixed in a distro release EPSS <1%CVSS 9.1
OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 2.3.1 and below, some OpenBao deployments intentionally limit privileged API operators from executing system code or making network connections. However, these operators can bypass both restrictions through the audit subsystem by manipulating log prefixes. This allows unauthorized code execution and network access that violates the intended security model. This issue is fixed in version 2.3.2. To workaround, users can block access to sys/audit/* endpoints using explicit deny policies, but root operators cannot be restricted this way.
Products: openbao
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/openbao/openbao | 2.3.2 |
| Go | github.com/openbao/openbao | 0.0.0-20250806194004-a14053c9679d |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| SUSE Linux Enterprise Module for Package Hub 15 SP6 | govulncheck-vulndb | 0.0.20250814T182633-150000.1.98.1 |
| openSUSE Leap 15.6 | govulncheck-vulndb | 0.0.20250814T182633-150000.1.98.1 |
| openSUSE Tumbleweed | govulncheck-vulndb | 0.0.20250811T192933-1.1 |