CVE-2025-54417
Fixed upstream EPSS <1%CVSS 5.2
Craft is a platform for creating digital experiences. Versions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: "Craft CMS has a potential RCE with a compromised security key". To exploit this vulnerability, the project must meet these requirements: have a compromised security key and create an arbitrary file in Craft's /storage/backups folder. With those criteria in place, attackers could create a specific, malicious request to the /updater/restore-db endpoint and execute CLI commands remotely. This issue is fixed in versions 4.16.3 and 5.8.4.
Products: craftcms cms
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Packagist | craftcms/cms | 4.16.3 |
| Packagist | craftcms/cms | 5.8.4 |