CVE-2025-53021
Fixed upstream EPSS <1%CVSS 4.2
A session fixation vulnerability in Moodle 3.x through 3.11.18 allows unauthenticated attackers to hijack user sessions via the sesskey parameter. The sesskey can be obtained without authentication and reused within the OAuth2 login flow, resulting in the victim's session being linked to the attacker's. Successful exploitation results in full account takeover. According to the Moodle Releases page, "Bug fixes for security issues in 3.11.x ended 11 December 2023." NOTE: This vulnerability only affects products that are no longer supported by the maintainer.
Products: Moodle
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Packagist | moodle/moodle | 4.0.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Ubuntu Pro 16.04 LTS | moodle | no fix |
| Ubuntu Pro 18.04 LTS | moodle | no fix |