CVE-2025-49124
Fixed upstream EPSS <1%CVSS 8.4
Untrusted Search Path vulnerability in Apache Tomcat installer for Windows. During installation, the Tomcat installer for Windows used icacls.exe without specifying a full path. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0 through 10.1.41, from 9.0.23 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100 and 7.0.95 through 7.0.109. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.
Products: Apache Software Foundation Apache Tomcat
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 11.0.8 |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 10.1.42 |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 9.0.106 |
| Maven | org.apache.tomcat:tomcat | 11.0.8 |
| Maven | org.apache.tomcat:tomcat | 10.1.42 |
| Maven | org.apache.tomcat:tomcat | 9.0.106 |
| Maven | org.apache.tomcat:tomcat-catalina | 11.0.8 |
| Maven | org.apache.tomcat:tomcat-catalina | 10.1.42 |
| Maven | org.apache.tomcat:tomcat-catalina | 9.0.106 |