CVE-2025-48956
Fixed in a distro release EPSS <1%CVSS 7.5
vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.10.1.1, a Denial of Service (DoS) vulnerability can be triggered by sending a single HTTP GET request with an extremely large header to an HTTP endpoint. This results in server memory exhaustion, potentially leading to a crash or unresponsiveness. The attack does not require authentication, making it exploitable by any remote user. This vulnerability is fixed in 0.10.1.1.
Products: vllm-project vllm
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | vllm | 0.10.1.1 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | tritonserver-backend-vllm-24.04 | 24.04-r15 |
| Chainguard | tritonserver-backend-vllm-cuda-12.9 | 25.7.1_git20250821-r1 |
| Chainguard | tritonserver-backend-vllm-meta-cuda-12.9 | 25.7.1_git20250821-r1 |