Patchwire CVEs, their patch status, and feeds to follow them

CVE-2025-48944

Fixed upstream EPSS <1%CVSS 6.5

vLLM is an inference and serving engine for large language models (LLMs). In version 0.8.0 up to but excluding 0.9.0, the vLLM backend used with the /v1/chat/completions OpenAPI endpoint fails to validate unexpected or malformed input in the "pattern" and "type" fields when the tools functionality is invoked. These inputs are not validated before being compiled or parsed, causing a crash of the inference worker with a single request. The worker will remain down until it is restarted. Version 0.9.0 fixes the issue.

Published 2025-05-30 · CVE record · OSV

Products: vllm-project vllm

Fixed upstream

EcosystemPackageFixed in
PyPIvllm0.9.0