CVE-2025-48943
Fixed in a distro release EPSS <1%CVSS 6.5
vLLM is an inference and serving engine for large language models (LLMs). Version 0.8.0 up to but excluding 0.9.0 have a Denial of Service (ReDoS) that causes the vLLM server to crash if an invalid regex was provided while using structured output. This vulnerability is similar to GHSA-6qc9-v4r8-22xg/CVE-2025-48942, but for regex instead of a JSON schema. Version 0.9.0 fixes the issue.
Products: vllm-project vllm
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | vllm | 0.9.0 |
| PyPI | vllm | 08bf7840780980c7568c573c70a6a8db94fd45ff |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | py3.10-vllm-cuda-11.8 | 0.9.0-r0 |
| Chainguard | py3.10-vllm-cuda-12.6 | 0.9.0.1-r0 |
| Chainguard | py3.10-wheels-vllm-cuda-11.8 | 0.9.0-r0 |
| Chainguard | tritonserver-backend-vllm-24.04 | 24.04-r10 |