Patchwire CVEs, their patch status, and feeds to follow them

CVE-2025-48942

Fixed upstream EPSS <1%CVSS 6.5

vLLM is an inference and serving engine for large language models (LLMs). In versions 0.8.0 up to but excluding 0.9.0, hitting the /v1/completions API with a invalid json_schema as a Guided Param kills the vllm server. This vulnerability is similar GHSA-9hcf-v7m4-6m2j/CVE-2025-48943, but for regex instead of a JSON schema. Version 0.9.0 fixes the issue.

Published 2025-05-30 · CVE record · OSV

Products: vllm-project vllm

Fixed upstream

EcosystemPackageFixed in
PyPIvllm0.9.0
PyPIvllm08bf7840780980c7568c573c70a6a8db94fd45ff