CVE-2025-48371
Fixed in a distro release EPSS <1%CVSS 5.8
OpenFGA is an authorization/permission engine. OpenFGA versions 1.8.0 through 1.8.12 (corresponding to Helm chart openfga-0.2.16 through openfga-0.2.30 and docker 1.8.0 through 1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users are affected under four specific conditions: First, calling Check API or ListObjects with an authorization model that has a relationship directly assignable by both type bound public access and userset; second, there are check or list object queries with contextual tuples for the relationship that can be directly assignable by both type bound public access and userset; third, those contextual tuples’s user field is an userset; and finally, type bound public access tuples are not assigned to the relationship. Users should upgrade to version 1.8.13 to receive a patch. The upgrade is backwards compatible.
Products: openfga
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/openfga/openfga | 1.8.13 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | grafana-11.3 | 11.3.7-r1 |
| Chainguard | grafana-11.4 | 11.4.5-r1 |
| Chainguard | grafana-11.5 | 11.5.5-r1 |
| Chainguard | grafana-11.5-oci-compat | 11.5.5-r1 |
| Chainguard | grafana-11.6 | 11.6.2-r1 |
| Chainguard | grafana-11.6-oci-compat | 11.6.2-r1 |
| Chainguard | grafana-12.0 | 12.0.1-r2 |
| Chainguard | grafana-12.0-oci-compat | 12.0.1-r2 |
| Chainguard | grafana-fips-11.4 | 11.4.5-r0 |
| Chainguard | grafana-fips-11.4-oci-compat | 11.4.5-r0 |
| Chainguard | grafana-fips-11.5 | 11.5.5-r0 |
| Chainguard | grafana-fips-11.5-oci-compat | 11.5.5-r0 |
| Chainguard | grafana-fips-11.6 | 11.6.2-r1 |
| Chainguard | grafana-fips-11.6-oci-compat | 11.6.2-r1 |
| Chainguard | grafana-fips-12.0 | 12.0.1-r1 |
| Chainguard | grafana-fips-12.0-oci-compat | 12.0.1-r1 |
| openSUSE Tumbleweed | govulncheck-vulndb | 0.0.20250527T204717-1.1 |