CVE-2025-47944
Fixed in a distro release EPSS <1%CVSS 7.5
Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.
Products: expressjs multer
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | multer | 2.0.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | grafana-image-renderer | 3.12.6-r0 |
| Wolfi | grafana-image-renderer | 3.12.6-r0 |