CVE-2025-46646
Fixed in a distro release EPSS <1%CVSS 4.5
In Artifex Ghostscript before 10.05.0, decode_utf8 in base/gp_utf8.c mishandles overlong UTF-8 encoding. NOTE: this issue exists because of an incomplete fix for CVE-2024-46954.
Products: artifex ghostscript
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Alpine 3.18 | ghostscript | 10.05.1 |
| Alpine 3.19 | ghostscript | 10.05.1-r0 |
| Alpine 3.20 | ghostscript | 10.05.1-r0 |
| Alpine 3.21 | ghostscript | 10.05.1-r0 |
| Alpine 3.22 | ghostscript | 10.05.1-r0 |
| Alpine 3.23 | ghostscript | 10.05.1-r0 |
| Debian 13 | ghostscript | 10.05.0~dfsg-1 |
| Debian 14 | ghostscript | 10.05.0~dfsg-1 |
| Ubuntu 24.04 LTS | ghostscript | 10.02.1~dfsg1-0ubuntu7.6 |
| openSUSE Leap 16.0 | ghostscript | 10.06.0-160000.1.1 |
| openSUSE Tumbleweed | ghostscript | 10.05.1-1.1 |