CVE-2025-46560
Fixed in a distro release EPSS <1%CVSS 6.5
vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.8.0 and prior to 0.8.5 are affected by a critical performance vulnerability in the input preprocessing logic of the multimodal tokenizer. The code dynamically replaces placeholder tokens (e.g., <|audio_|>, <|image_|>) with repeated tokens based on precomputed lengths. Due to inefficient list concatenation operations, the algorithm exhibits quadratic time complexity (O(n²)), allowing malicious actors to trigger resource exhaustion via specially crafted inputs. This issue has been patched in version 0.8.5.
Products: vllm-project vllm
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | vllm | 0.8.5 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | py3.10-vllm-cuda-11.8 | 0.8.5-r1 |
| Chainguard | py3.10-vllm-cuda-12.6 | 0.8.5-r1 |
| Chainguard | py3.10-wheels-vllm-cuda-11.8 | 0.8.5-r1 |
| Chainguard | tritonserver-backend-vllm-24.04 | 24.04-r17 |