CVE-2025-3512
Fixed in a distro release EPSS <1%CVSS 4.8
There is a Heap-based Buffer Overflow vulnerability in QTextMarkdownImporter. This requires an incorrectly formatted markdown file to be passed to QTextMarkdownImporter to trigger the overflow. This issue affects Qt from 6.8.0 to 6.8.4. Versions up to 6.6.0 are known to be unaffected, and the fix is in 6.8.4 and later.
Products: qt
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 13 | qt6-base | 6.8.2+dfsg-6 |
| Debian 14 | qt6-base | 6.8.2+dfsg-6 |
| Ubuntu 16.04 LTS | qtbase-opensource-src-gles | no fix |
| Ubuntu 20.04 LTS | qtbase-opensource-src-gles | no fix |
| Ubuntu 22.04 LTS | qt6-base | no fix |
| Ubuntu 22.04 LTS | qtbase-opensource-src-gles | no fix |
| Ubuntu 24.04 LTS | qt6-base | no fix |
| Ubuntu 24.04 LTS | qtbase-opensource-src-gles | no fix |
| Ubuntu 25.10 | qt6-base | no fix |
| Ubuntu 25.10 | qtbase-opensource-src-gles | no fix |
| Ubuntu 26.04 LTS | qt6-base | no fix |
| Ubuntu 26.04 LTS | qtbase-opensource-src-gles | no fix |
| Ubuntu 26.10 | qt6-base | no fix |
| Ubuntu 26.10 | qtbase-opensource-src-gles | no fix |