Patchwire CVEs, their patch status, and feeds to follow them

CVE-2025-32444

Fixed upstream EPSS 2%CVSS 10.0

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.6.5 and prior to 0.8.5, having vLLM integration with mooncake, are vulnerable to remote code execution due to using pickle based serialization over unsecured ZeroMQ sockets. The vulnerable sockets were set to listen on all network interfaces, increasing the likelihood that an attacker is able to reach the vulnerable ZeroMQ sockets to carry out an attack. vLLM instances that do not make use of the mooncake integration are not vulnerable. This issue has been patched in version 0.8.5.

Published 2025-04-30 · CVE record · OSV

Products: vllm-project vllm

Fixed upstream

EcosystemPackageFixed in
PyPIvllm0.8.5
PyPIvllma5450f11c95847cf51a17207af9a3ca5ab569b2c