CVE-2025-32434
Fixed in a distro release EPSS 2%CVSS 9.3
PyTorch is a Python package that provides tensor computation with strong GPU acceleration and deep neural networks built on a tape-based autograd system. In version 2.5.1 and prior, a Remote Command Execution (RCE) vulnerability exists in PyTorch when loading a model using torch.load with weights_only=True. This issue has been patched in version 2.6.0.
Products: pytorch
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | torch | 2.6.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | py3.10-torch-2.3-cuda-12.4 | no fix |
| Debian 11 | pytorch | 1.7.1-7+deb11u1 |
| Debian 12 | pytorch | no fix |
| Debian 13 | pytorch | 2.6.0+dfsg-1 |
| Debian 14 | pytorch | 2.6.0+dfsg-1 |