CVE-2025-32364
Fixed in a distro release EPSS <1%CVSS 4.0
A floating-point exception in the PSStack::roll function of Poppler before 25.04.0 can cause an application to crash when handling malformed inputs associated with INT_MIN.
Products: freedesktop poppler
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 11 | poppler | 20.09.0-3.1+deb11u2 |
| Debian 12 | poppler | 22.12.0-2+deb12u1 |
| Debian 13 | poppler | 25.03.0-3 |
| Debian 14 | poppler | 25.03.0-3 |
| SUSE Linux Enterprise Module for Basesystem 15 SP6 | poppler | 24.03.0-150600.3.10.1 |
| SUSE Linux Enterprise Module for Basesystem 15 SP6 | poppler | 0.79.0-150200.3.38.1 |
| SUSE Linux Enterprise Module for Package Hub 15 SP6 | poppler | 24.03.0-150600.3.10.1 |
| SUSE Linux Enterprise Module for Package Hub 15 SP6 | poppler-qt5 | 24.03.0-150600.3.10.1 |
| SUSE Linux Enterprise Module for Package Hub 15 SP6 | poppler-qt6 | 24.03.0-150600.3.10.1 |
| SUSE Linux Enterprise Server LTSS Extended Security 12 SP5 | poppler | 0.43.0-16.55.1 |
| SUSE Linux Enterprise Server LTSS Extended Security 12 SP5 | poppler-qt | 0.43.0-16.55.1 |
| Ubuntu 20.04 LTS | poppler | 0.86.1-0ubuntu1.6 |
| Ubuntu 22.04 LTS | poppler | 22.02.0-2ubuntu0.7 |
| Ubuntu 24.04 LTS | poppler | 24.02.0-1ubuntu9.3 |
| Ubuntu Pro 16.04 LTS | poppler | 0.41.0-0ubuntu1.16+esm6 |
| Ubuntu Pro 18.04 LTS | poppler | 0.62.0-2ubuntu2.14+esm5 |
| openSUSE Leap 15.6 | poppler | 24.03.0-150600.3.10.1 |
| openSUSE Leap 15.6 | poppler-qt5 | 24.03.0-150600.3.10.1 |
| openSUSE Leap 15.6 | poppler-qt6 | 24.03.0-150600.3.10.1 |
| openSUSE Tumbleweed | poppler | 25.04.0-1.1 |