CVE-2025-31675
Fixed upstream EPSS <1%CVSS 5.4
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).This issue affects Drupal core: from 8.0.0 before 10.3.14, from 10.4.0 before 10.4.5, from 11.0.0 before 11.0.13, from 11.1.0 before 11.1.5. It also affects the Drupal 7 module from versions 7.x-1.0 through 7.x-1.12.
Products: Drupal Core, Drupal Link
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Packagist | drupal/core | 10.3.14 |
| Packagist | drupal/core | 10.4.5 |
| Packagist | drupal/core | 11.0.13 |
| Packagist | drupal/core | 11.1.5 |