CVE-2025-3154
Fixed in a distro release EPSS <1%CVSS 2.1
Out-of-bounds array write in Xpdf 4.05 and earlier, triggered by an invalid VerticesPerRow value in a PDF shading dictionary.
Products: xpdf
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| SUSE Linux Enterprise Server LTSS Extended Security 12 SP5 | poppler | 0.43.0-16.67.1 |
| SUSE Linux Enterprise Server LTSS Extended Security 12 SP5 | poppler-qt | 0.43.0-16.67.1 |
| Ubuntu 16.04 LTS | ipe | no fix |
| Ubuntu 16.04 LTS | xpdf | no fix |
| Ubuntu 18.04 LTS | ipe | no fix |
| Ubuntu 18.04 LTS | xpdf | no fix |
| Ubuntu 20.04 LTS | ipe | no fix |
| Ubuntu 22.04 LTS | ipe | no fix |
| Ubuntu 22.04 LTS | xpdf | no fix |
| Ubuntu 24.04 LTS | ipe | no fix |
| Ubuntu 24.04 LTS | xpdf | no fix |
| Ubuntu 25.10 | ipe | no fix |
| Ubuntu 25.10 | xpdf | no fix |
| Ubuntu 26.04 LTS | ipe | no fix |
| Ubuntu 26.04 LTS | xpdf | no fix |
| Ubuntu 26.10 | ipe | no fix |
| Ubuntu 26.10 | xpdf | no fix |