CVE-2025-29927
Fixed in a distro release EPSS 99%CVSS 9.1
Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.
Products: vercel next.js
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | next | 13.5.9 |
| npm | next | 14.2.25 |
| npm | next | 15.2.3 |
| npm | next | 12.3.5 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | jitsucom-jitsu | 2.9.0-r0 |
| Chainguard | jitsucom-jitsu-console | 2.9.0-r0 |
| Chainguard | jitsucom-jitsu-rotor | 2.9.0-r0 |
| Wolfi | jitsucom-jitsu | 2.9.0-r0 |
| Wolfi | jitsucom-jitsu-console | 2.9.0-r0 |
| Wolfi | jitsucom-jitsu-rotor | 2.9.0-r0 |