CVE-2025-2945
Fixed in a distro release EPSS 56%CVSS 9.9
Remote Code Execution security vulnerability in pgAdmin 4 (Query Tool and Cloud Deployment modules). The vulnerability is associated with the 2 POST endpoints; /sqleditor/query_tool/download, where the query_commited parameter and /cloud/deploy endpoint, where the high_availability parameter is unsafely passed to the Python eval() function, allowing arbitrary code execution. This issue affects pgAdmin 4: before 9.2.
Products: pgadmin.org pgAdmin 4
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | pgadmin4 | 9.2 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE Tumbleweed | pgadmin4 | 9.2-1.1 |