CVE-2025-2866
Fixed in a distro release EPSS <1%CVSS 2.4
Improper Verification of Cryptographic Signature vulnerability in LibreOffice allows PDF Signature Spoofing by Improper Validation. In the affected versions of LibreOffice a flaw in the verification code for adbe.pkcs7.sha1 signatures could cause invalid signatures to be accepted as valid This issue affects LibreOffice: from 24.8 before < 24.8.6, from 25.2 before < 25.2.2.
Products: The Document Foundation LibreOffice
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 11 | libreoffice | 1:7.0.4-4+deb11u13 |
| Debian 12 | libreoffice | 4:7.4.7-1+deb12u8 |
| Debian 13 | libreoffice | 4:25.2.2-1 |
| Debian 14 | libreoffice | 4:25.2.2-1 |
| Ubuntu 20.04 LTS | libreoffice | 1:6.4.7-0ubuntu0.20.04.15 |
| Ubuntu 22.04 LTS | libreoffice | 1:7.3.7-0ubuntu0.22.04.10 |
| Ubuntu 24.04 LTS | libreoffice | 4:24.2.7-0ubuntu0.24.04.4 |