CVE-2025-2849
Fixed in a distro release EPSS <1%CVSS 3.3
A vulnerability, which was classified as problematic, was found in UPX up to 5.0.0. Affected is the function PackLinuxElf64::un_DT_INIT of the file src/p_lx_elf.cpp. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used. The patch is identified as e0b6ff192412f5bb5364c1948f4f6b27a0cd5ea2. It is recommended to apply a patch to fix this issue.
Products: upx
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | upx-doc | 5.0.1-r0 |
| Debian 13 | upx-ucl | 4.2.4-1.1 |
| Debian 14 | upx-ucl | 4.2.4-1.1 |
| Ubuntu 16.04 LTS | upx-ucl | no fix |
| Ubuntu 18.04 LTS | upx-ucl | no fix |
| Ubuntu 20.04 LTS | upx-ucl | no fix |
| Ubuntu 22.04 LTS | upx-ucl | no fix |
| Ubuntu 24.04 LTS | upx-ucl | no fix |
| Ubuntu 25.10 | upx-ucl | no fix |
| Ubuntu 26.04 LTS | upx-ucl | no fix |
| Ubuntu 26.10 | upx-ucl | no fix |
| Wolfi | upx-doc | 5.0.1-r0 |
| openSUSE Tumbleweed | upx | 5.0.0-2.1 |