CVE-2025-27788
Fixed in a distro release EPSS <1%CVSS 7.5
JSON is a JSON implementation for Ruby. Starting in version 2.10.0 and prior to version 2.10.2, a specially crafted document could cause an out of bound read, most likely resulting in a crash. Versions prior to 2.10.0 are not vulnerable. Version 2.10.2 fixes the problem. No known workarounds are available.
Products: ruby json
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| RubyGems | json | 2.10.2 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | ruby3.2-fluentd-kubernetes-daemonset-1.16 | 1.16.7.1.1-r1 |
| Chainguard | ruby3.2-fluentd-kubernetes-daemonset-1.16-kinesis | 1.16.7.1.1-r1 |
| Chainguard | ruby3.2-json | 2.10.2-r0 |
| Chainguard | ruby3.3-fluentd-kubernetes-daemonset-1.16 | 1.16.7.1.1-r1 |
| Chainguard | ruby3.3-fluentd-kubernetes-daemonset-1.16-kinesis | 1.16.7.1.1-r1 |
| Chainguard | ruby3.3-json | 2.10.2-r0 |
| Chainguard | ruby3.4-fluentd-kubernetes-daemonset-1.16 | 1.16.8.1.0-r0 |
| Chainguard | ruby3.4-fluentd-kubernetes-daemonset-1.16-kinesis | 1.16.8.1.0-r0 |
| Chainguard | ruby3.4-json | 2.10.2-r0 |
| Wolfi | ruby3.2-json | 2.10.2-r0 |
| Wolfi | ruby3.3-json | 2.10.2-r0 |
| Wolfi | ruby3.4-json | 2.10.2-r0 |