CVE-2025-27427
Fixed in a distro release EPSS <1%CVSS 2.3
A vulnerability exists in Apache ActiveMQ Artemis whereby a user with the createDurableQueue or createNonDurableQueue permission on an address can augment the routing-type supported by that address even if said user doesn't have the createAddress permission for that particular address. When combined with the send permission and automatic queue creation a user could successfully send a message with a routing-type not supported by the address when that message should actually be rejected on the basis that the user doesn't have permission to change the routing-type of the address. This issue affects Apache ActiveMQ Artemis from 2.0.0 through 2.39.0. Users are recommended to upgrade to version 2.40.0 which fixes the issue.
Products: Apache Software Foundation Apache ActiveMQ Artemis
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.activemq:artemis-server | 2.40.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | wildfly | 35.0.1-r17 |
| Chainguard | wildfly-openjdk-17 | 35.0.1-r17 |
| Chainguard | wildfly-openjdk-17-compat | 35.0.1-r17 |
| Chainguard | wildfly-openjdk-21 | 35.0.1-r17 |
| Chainguard | wildfly-openjdk-21-compat | 35.0.1-r17 |
| Wolfi | wildfly | 35.0.1-r17 |
| Wolfi | wildfly-openjdk-17 | 35.0.1-r17 |
| Wolfi | wildfly-openjdk-17-compat | 35.0.1-r17 |
| Wolfi | wildfly-openjdk-21 | 35.0.1-r17 |
| Wolfi | wildfly-openjdk-21-compat | 35.0.1-r17 |