CVE-2025-2704
Fixed in a distro release EPSS <1%CVSS 7.5
OpenVPN version 2.6.1 through 2.6.13 in server mode using TLS-crypt-v2 allows remote attackers to trigger a denial of service by corrupting and replaying network packets in the early handshake phase
Products: OpenVPN
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Alpine 3.19 | openvpn | 2.6.16-r0 |
| Alpine 3.20 | openvpn | 2.6.16-r0 |
| Alpine 3.21 | openvpn | 2.6.14-r0 |
| Alpine 3.22 | openvpn | 2.6.14-r0 |
| Alpine 3.23 | openvpn | 2.6.14-r0 |
| Alpine 3.24 | openvpn | 2.6.14-r0 |
| Debian 12 | openvpn | 2.6.3-1+deb12u3 |
| Debian 13 | openvpn | 2.6.14-1 |
| Debian 14 | openvpn | 2.6.14-1 |
| SUSE Linux Enterprise Module for Basesystem 15 SP6 | openvpn | 2.6.8-150600.3.17.1 |
| SUSE Linux Enterprise Module for Basesystem 15 SP6 | openvpn-dco | 2.6.8-150600.3.17.1 |
| SUSE Linux Enterprise Module for Basesystem 15 SP7 | openvpn | 2.6.8-150600.3.17.1 |
| SUSE Linux Enterprise Module for Basesystem 15 SP7 | openvpn-dco | 2.6.8-150600.3.17.1 |
| Ubuntu 24.04 LTS | openvpn | 2.6.12-0ubuntu0.24.04.3 |
| openSUSE Leap 15.6 | openvpn | 2.6.8-150600.3.17.1 |
| openSUSE Leap 15.6 | openvpn-dco | 2.6.8-150600.3.17.1 |
| openSUSE Tumbleweed | openvpn | 2.6.14-1.1 |