CVE-2025-27018
Fixed in a distro release EPSS <1%CVSS 6.3
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow MySQL Provider. When user triggered a DAG with dump_sql or load_sql functions they could pass a table parameter from a UI, that could cause SQL injection by running SQL that was not intended. It could lead to data corruption, modification and others. This issue affects Apache Airflow MySQL Provider: before 6.2.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue.
Products: Apache Software Foundation Apache Airflow MySQL Provider
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | apache-airflow-providers-mysql | 6.2.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | airflow | 2.10.5-r3 |
| Chainguard | airflow-bitnami-compat | 2.10.5-r3 |
| Chainguard | airflow-compat | 2.10.5-r3 |
| Wolfi | airflow | 2.10.5-r3 |
| Wolfi | airflow-bitnami-compat | 2.10.5-r3 |
| Wolfi | airflow-compat | 2.10.5-r3 |