CVE-2025-26803
Fixed in a distro release EPSS <1%CVSS 5.3
The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
Products: phusion passenger
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| RubyGems | passenger | 6.0.26 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 13 | passenger | 6.0.26+ds-1 |
| Debian 14 | passenger | 6.0.26+ds-1 |
| Ubuntu 25.10 | passenger | no fix |
| Ubuntu 26.04 LTS | passenger | no fix |
| Ubuntu 26.10 | passenger | no fix |