CVE-2025-26520
Fixed in a distro release EPSS <1%CVSS 7.6
Cacti through 1.2.29 allows SQL injection in the template function in host_templates.php via the graph_template parameter. NOTE: this issue exists because of an incomplete fix for CVE-2024-54146.
Products: cacti
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 13 | cacti | 1.2.30+ds1-1 |
| Debian 14 | cacti | 1.2.30+ds1-1 |
| Ubuntu 24.04 LTS | cacti | no fix |
| Ubuntu 25.10 | cacti | no fix |
| Ubuntu 26.04 LTS | cacti | no fix |
| Ubuntu 26.10 | cacti | no fix |
| Ubuntu Pro 14.04 LTS | cacti | no fix |
| Ubuntu Pro 16.04 LTS | cacti | no fix |
| Ubuntu Pro 18.04 LTS | cacti | no fix |
| Ubuntu Pro 20.04 LTS | cacti | no fix |
| Ubuntu Pro 22.04 LTS | cacti | no fix |