CVE-2025-24814
Fixed in a distro release EPSS 1%CVSS 5.4
Core creation allows users to replace "trusted" configset files with arbitrary configuration Solr instances that (1) use the "FileSystemConfigSetService" component (the default in "standalone" or "user-managed" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual "trusted" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem. These replacement config files are treated as "trusted" and can use "<lib>" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin. This issue affects all Apache Solr versions up through Solr 9.7. Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from "FileSystemConfigSetService"). Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of "<lib>" tags by default.
Products: Apache Software Foundation Apache Solr
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.solr:solr-core | 9.8.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | hadoop-fips-3.3.6 | no fix |
| Chainguard | hadoop-fips-3.4.2 | no fix |
| Chainguard | hadoop-fips-3.5 | no fix |
| Chainguard | solr | 0 |
| Chainguard | solr-oci-compat | 0 |
| Debian 12 | lucene-solr | 3.6.2+dfsg-23 |
| Debian 13 | lucene-solr | 3.6.2+dfsg-23 |
| Debian 14 | lucene-solr | 3.6.2+dfsg-23 |
| Ubuntu 20.04 LTS | lucene-solr | no fix |
| Ubuntu Pro 14.04 LTS | lucene-solr | no fix |
| Ubuntu Pro 16.04 LTS | lucene-solr | no fix |
| Ubuntu Pro 18.04 LTS | lucene-solr | no fix |
| Wolfi | solr | 0 |
| Wolfi | solr-oci-compat | 0 |