Patchwire CVEs, their patch status, and feeds to follow them

CVE-2025-24017

Fixed upstream EPSS <1%CVSS 7.6

YesWiki is a wiki system written in PHP. Versions up to and including 4.4.5 are vulnerable to any end-user crafting a DOM based XSS on all of YesWiki's pages which is triggered when a user clicks on a malicious link. The vulnerability makes use of the search by tag feature. When a tag doesn't exist, the tag is reflected on the page and isn't properly sanitized on the server side which allows a malicious user to generate a link that will trigger an XSS on the client's side when clicked. This vulnerability allows any user to generate a malicious link that will trigger an account takeover when clicked, therefore allowing a user to steal other accounts, modify pages, comments, permissions, extract user data (emails), thus impacting the integrity, availability and confidentiality of a YesWiki instance. Version 4.5.0 contains a patch for the issue.

Published 2025-01-21 · CVE record · OSV

Products: yeswiki

Fixed upstream

EcosystemPackageFixed in
Packagistyeswiki/yeswiki4.5.0