CVE-2025-23391
Fixed in a distro release EPSS <1%CVSS 9.1
A Incorrect Privilege Assignment vulnerability in SUSE rancher allows a Restricted Administrator to change the password of Administrators and take over their accounts. This issue affects rancher: from 2.8.0 before 2.8.14, from 2.9.0 before 2.9.8, from 2.10.0 before 2.10.4.
Products: SUSE Rancher
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/rancher/rancher | 2.8.14 |
| Go | github.com/rancher/rancher | 2.9.8 |
| Go | github.com/rancher/rancher | 2.10.4 |
| Go | github.com/rancher/rancher | no fix |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | harvester | 1.8.1-r1 |
| Chainguard | harvester-fips | 1.8.1-r0 |
| Chainguard | harvester-fips-webhook | 1.8.1-r0 |
| Chainguard | harvester-webhook | 1.8.1-r1 |
| openSUSE Tumbleweed | govulncheck-vulndb | 0.0.20250402T160203-1.1 |