Patchwire CVEs, their patch status, and feeds to follow them

CVE-2025-23015

Fixed in a distro release EPSS 1%CVSS 8.8

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Published 2025-02-04 · CVE record · OSV

Products: Apache Software Foundation Apache Cassandra

Fixed upstream

EcosystemPackageFixed in
Mavenorg.apache.cassandra:cassandra-all5.0.3
Mavenorg.apache.cassandra:cassandra-all4.1.8
Mavenorg.apache.cassandra:cassandra-all4.0.16
Mavenorg.apache.cassandra:cassandra-all3.11.18
Mavenorg.apache.cassandra:cassandra-all3.0.31

Distro releases

ReleasePackageFixed in
Chainguarddruidno fix
Chainguarddruid-compat34.0.0-r6
Wolfidruidno fix
Wolfidruid-compat34.0.0-r6